فریب پیامک‌های “شما برنده قرعه‌کشی شده‌اید” را نخورید
فریب پیامک‌های “شما برنده قرعه‌کشی شده‌اید” را نخورید
شهریور ۲۵, ۱۳۹۶
سریعترین رشد زبان پایتون در میان زبان های برنامه نویسی
سریعترین رشد زبان پایتون در میان زبان های برنامه نویسی
شهریور ۲۷, ۱۳۹۶

افزونه Display widgets دویست هزار سایت وردپرسی را قربانی کرد

افزونه Display widgets دویست هزار سایت وردپرسی را قربانی کرد

افزونه Display widgets دویست هزار سایت وردپرسی را قربانی کرد

افزونه Display widgets دویست هزار سایت وردپرسی را قربانی کرد

 

 

پژوهش‌های به عمل آمده نشان می‌دهد توسعه‌دهنده اصلی این افزونه کاربردی در تاریخ ۱۹ می سال جاری میلادی افزونه فوق را به مبلغ ۱۵ هزار دلار به توسعه‌دهنده دیگری فروخته است. پس از این خرید به فاصله یک ماه بعد افزونه فوق رفتارهای مخربی را از خود نشان داد. در ادامه افزونه فوق بارها شاهد دریافت به‌روزرسانی‌های متعددی بود و تاکنون چند بار از مخزن افزونه‌ها نیز حذف شده است. اولین فعالیت مخرب افزونه Display Widgets همراه با عرضه نسخه ۲٫۶ در تاریخ ۱۲ ژوئن شناسایی شد و دو بعد از مخزن افزونه‌ها حذف گردید. این نسخه اصلاح شده ۳۸ مگابایت کد را از یک سرور خارجی دانلود می‌کرد.  به فاصله ۱۸ روز از این تاریخ نسخه ۲٫۶٫۱ این افزونه یکبار دیگر و این بار همراه با فایل مخرب geolocation.php عرضه شد.

 افزونه به‌روزرسانی شده محتوایی را برای سایت‌هایی که این افزونه روی آن‌ها فعال بود ارسال می‌کرد. اما کدهای به‌روزشده افزونه فوق به گونه‌ای بودند که به توسعه‌دهنده افزونه اجازه می‌دادند محتوای ارسالی برای سایت‌ها را به‌روزرسانی کرده، حذف کرده یا مانع از آن شود تا مخاطبان سایت محتوا را مشاهده کنند. افزونه به‌روزرسانی شده یکبار دیگر در تاریخ ۱ جولای از مخزن وردپرس حذف شد. نسخه ۲٫۶٫۲ افزونه فوق درست یک هفته بعد و در تاریخ ۲۴ جولای منتشر شد که بلافاصله حذف گردید. جدیدترین نسخه از افزونه فوق در تاریخ ۸ سپتامبر و در قالب نسخه ۲٫۶٫۳ با اصلاح کدهای مخرب و برطرف کردن باگ‌های کدهای مخرب مجددا منتشر شد.

در حالی که افزونه فوق چند مرتبه از مخزن وردپرس حذف گردیده است، اما مالکان افزونه فوق اصرار دارند که هیچ کد مخربی درون افزونه فوق قرار نداشته و تنها یک آسیب‌پذیری درون این افزونه قرار دارد. همین موضوع باعث شده است که آسیب‌پذیری فوق در ترکیب با سایر افزونه‌ها اقدام به نمایش هرزنامه‌ها کرده و از سوی هکرها مورد سوء استفاده قرار گیرد. اما Wordfence می‌گوید: «تحلیل‌های انجام شده نشان می‌دهد این کدها آسیب‌پذیری نبوده و یک درب پشتی هستند که به مالکان توسعه‌دهنده اجازه می‌دهند مطالبی را روی سایت‌ها منتشر سازند. سایت‌هایی که از نسخه ۲٫۶٫۱ تا ۲٫۶٫۳٫۱ افزونه Display Widgets استفاده کرده‌اند همگی به کدهای مخرب آلوده هستند و این احتمال وجود دارد که مخاطبان آن سایت‌ها هرزنامه‌هایی را مشاهده کنند. توسعه‌دهندگان این افزونه هنوز هم قبول نمی‌کنند که در به‌روزرسانی این افزونه کدهای مخربی را وارد کرده‌اند.»

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *